# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http|https|ftp)\://([a-zA-Z0-9\-\.]+\.+[a-zA-Z]{2,3})(:[a-zA-Z0-9]*)?/?([a-zA-Z0-9\-\._\?\,\'/\\\+&%\$#\=~]*)[^\.\,\)\(\s]?"
test_str = ("appro@openssl.org\n"
"appro@openssl.org\n"
"appro@openssl.org\n"
"appro@openssl.org\n"
"appro@openssl.org\n"
"http://www.openssl.org/support/faq.html\n"
"www.openssl.org/support/faq.html\n"
"http://www.openssl.org/support/faq.html\n"
"d.compressedData\n"
"https://\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.001\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.001\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.002\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.002\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.003\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.003\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.004\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.004\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.005\n"
"http://zip.allnetserveline.com/crossbrowse/chrome/chrome.zip.005\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.001\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.001\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.002\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.002\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.003\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.003\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.004\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.004\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.005\n"
"http://zipf.allnetserveline.com/crossbrowse/chrome/chrome.zip.005\n"
"http://err.allnetserveline.com\n"
"http://err.allnetserveline.com\n"
"http://logs.allnetserveline.com\n"
"http://logs.allnetserveline.com\n"
"http://stats.allnetserveline.com\n"
"http://stats.allnetserveline.com\n"
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js\n"
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js\n"
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json\n"
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json\n"
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js\n"
"http://js.allnetserveline.com/crossbrowse/js/{{camp_id}}/{{secret}}/ch.js\n"
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json\n"
"http://srch.allnetserveline.com/crossbrowse/sch/{{camp_id}}/{{secret}}/ch.json\n"
"http://update.allnetserveline.com/crossbrowse/updater/{{camp_id}}/{{version}}/{{secret}}/update.json\n"
"http://update.allnetserveline.com/crossbrowse/updater/{{camp_id}}/{{version}}/{{secret}}/update.json\n"
"http://ipgeoapi.com/\n"
"http://ipgeoapi.com/\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.