$re = '/(.+)\s*(?={)|^[\t\s]*(.+;)/m';
$str = '.grid-container {
display: grid;
grid-template-rows: 100px 200px;
}
div.target.dunes {
background-color: green;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);