const regex = /\]\((.+)(?=(\.(svg|gif|png|jpe?g)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\]\\((.+)(?=(\\.(svg|gif|png|jpe?g)))', 'gm')
const str = `# Example header
**example subheader**

Some example text in between

# Example header
Some more example text.

But (blabla.png) wil not be transformed`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}