package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([af][ .]?p[ .]?o|[Pp]*(OST|ost)*)\b\.*\s*[Oo0]*(ffice|FFICE)*\.*\s*[Bb][Oo0][Xx]`)
var str = `APO box
FPO
A.p.o
F.P.O
APOPKO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}