package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(border(?:-(?:top|bottom)-(?:left|right))?-radius)\s*:\s([^;]*)(?:;|$)`)
var str = `border-radius: 5px;
Border-Radius: 5px 6px;
border-top-left-radius: 5px;
border-top-right-radius: 5px;
border-bottom-left-radius: 5px;
border-bottom-right-radius: 5px;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}