#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)<\s* input [^>]+ >"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
" <html>" & @CRLF & _
" <head>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <form>" & @CRLF & _
" <label for="nome">Nome</label>" & @CRLF & _
" <input type="text" name="nome" id="nome"/><br><br>" & @CRLF & _
" <label for="email">email</label>" & @CRLF & _
" <input type="text" name="email" id="email"/><br><br>" & @CRLF & _
" <input type="submit" value="Enviar">" & @CRLF & _
" </form>" & @CRLF & _
" </body>" & @CRLF & _
" </html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")