# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<\s* input [^>]+ >
"""
test_str = ("<!DOCTYPE html>\n"
" <html>\n"
" <head>\n"
" </head>\n"
" <body>\n"
" <form>\n"
" <label for=\"nome\">Nome</label>\n"
" <input type=\"text\" name=\"nome\" id=\"nome\"/><br><br>\n"
" <label for=\"email\">email</label>\n"
" <input type=\"text\" name=\"email\" id=\"email\"/><br><br>\n"
" <input type=\"submit\" value=\"Enviar\">\n"
" </form>\n"
" </body>\n"
" </html>")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.