$re = '/www\.example\.com\/registration\/([^\/]+)/';
$str = 'www.example.com/registration/star-mega/x45xx/xxxrfxx/xx';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);