re = /www\.example\.com\/registration\/([^\/]+)/
str = 'www.example.com/registration/star-mega/x45xx/xxxrfxx/xx'
# Print the match result
str.match(re) do |match|
puts match.to_s
end