import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(^\\d\\s{3}(chr\\d)\\s{2}\\d+\\s+\\D+\\d+\\.\\d+\\s+\\w+(?=(?:(?:\\s+[01]/[01])*?\\s+1/1){3})(?:(?:(?:\\s+[01]/[01])*?\\s+0/0){3})(?:\\s+[01]/[01])*\\s(^\\d\\s{3}((chr\\d)\\s{2}\\d+\\s+\\D+\\d+\\.\\d+\\s+\\w+(?:\\s+[01]/[01])*\\s)){1,2}^\\d\\s{3}(chr\\d)\\s{2}\\d+\\s+\\D+\\d+\\.\\d+\\s+\\w+(?=(?:(?:\\s+[01]/[01])*?\\s+1/1){3})(?:(?:(?:\\s+[01]/[01])*?\\s+0/0){3})(?:\\s+[01]/[01])*\\s))|(^\\d\\s{3}(chr\\d)\\s{2}\\d+\\s+\\D+\\d+\\.\\d+\\s+\\w+(?=(?:(?:\\s+[01]/[01])*?\\s+1/1){3})(?:(?:(?:\\s+[01]/[01])*?\\s+0/0){3})(?:\\s+[01]/[01])*$)";
final String string = "0 chr1 1152 NaN G A 1355.64 NaN 1/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "4 chr1 1331 NaN A C 4171.07 NaN 0/0 0/1 0/1 0/1 0/0 0/1 0/1 0/1 0/1 0/0 0/1 0/1\n"
+ "5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0\n"
+ "5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0\n"
+ "6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 1/1 1/1 1/1 0/1 1/1 0/1 1/1 0/1 1/1\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0\n"
+ "5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 1/1 1/1 1/1 0/1 1/1 0/1 1/1 0/1 1/1\n"
+ "8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}