re = /(?=(^\d\s{3}(chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?=(?:(?:\s+[01]\/[01])*?\s+1\/1){3})(?:(?:(?:\s+[01]\/[01])*?\s+0\/0){3})(?:\s+[01]\/[01])*\s(^\d\s{3}((chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?:\s+[01]\/[01])*\s)){1,2}^\d\s{3}(chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?=(?:(?:\s+[01]\/[01])*?\s+1\/1){3})(?:(?:(?:\s+[01]\/[01])*?\s+0\/0){3})(?:\s+[01]\/[01])*\s))|(^\d\s{3}(chr\d)\s{2}\d+\s+\D+\d+\.\d+\s+\w+(?=(?:(?:\s+[01]\/[01])*?\s+1\/1){3})(?:(?:(?:\s+[01]\/[01])*?\s+0\/0){3})(?:\s+[01]\/[01])*$)/m
str = '0 chr1 1152 NaN G A 1355.64 NaN 1/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
4 chr1 1331 NaN A C 4171.07 NaN 0/0 0/1 0/1 0/1 0/0 0/1 0/1 0/1 0/1 0/0 0/1 0/1
5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 1/1 1/1 1/1 0/1 1/1 0/1 1/1 0/1 1/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0
5 chr1 1349 NaN T C 11194.50 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
6 chr1 1401 NaN T G 10825.80 NaN 0/1 0/1 0/1 0/1 1/1 0/1 0/1 0/1 0/1 1/1 0/1 0/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 1/1 1/1 1/1 0/1 1/1 0/1 1/1 0/1 1/1
8 chr1 4045 NaN G T 1917.92 NaN 1/1 1/1 1/1 0/0 0/0 0/0 0/1 0/0 0/0 0/0 0/0 0/0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end