import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<req_ip>^[\\d\\.]+)\\s+(?P<req_identity>.+?)\\s+(?P<req_user>.+?)\\s+(?P<req_date>.+?)\\s+(?P<req_offset>.+?)\\s+\"(?P<req_method>.+?)\\s+(?P<req_path>.+?)\\s+(?P<req_protocoll>.+?)\"\\s+(?P<req_code>.+?)\\s+(?P<req_size>.+?)\\s+\"(?P<req_referer>.+?)\"\\s+\"(?P<req_device>.+?)\"";
final String string = "165.72.104.6 - admin 12/May/2021:09:37:52 +0000 \"GET /etc/clientlibs/website/global/public/img/loading.gif HTTP/1.1\" 200 17585 \"https://my.domain.com/etc/clientlibs/website/global/public/stylesheets/project-base.108cb261dae9b1ccd0121c7571bbd42f2fc6d0a78a9bffb03b16be08753a32ad.css\" \"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}