$re = '/[a-zA-Z](?:[a-zA-Z\']*[a-zA-Z])?/';
$str = '\'hello\' world can\'t math\'tjs\'jvac a \' t gb \'\'\'dsf\' \'df\'\'\' @#$khw@#$% sdfsdf\'dsf\'sdf\'sdf jksk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);