re = /^\w+(-\w+)*$/m
str = 'home-bird
home--dog
home-dog-bird
test--test-test
-another-test
tets-tets--sdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end