#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^line3$"
Local $sString = "line1" & @CRLF & _
"" & @CRLF & _
"line2" & @CRLF & _
"" & @CRLF & _
"line3line4" & @CRLF & _
"" & @CRLF & _
"line5line3" & @CRLF & _
"" & @CRLF & _
"line3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")