using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^line3$";
string input = @"line1
line2
line3line4
line5line3
line3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}