const regex = new RegExp('<loc>(http:\\/\\/.+)<\\/loc>', '')
const str = `import urllib2 as ur
import re
f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')
res = f.readlines()
for d in res:
data = re.findall('<loc>(http:\\/\\/.+)<\\/loc>',d)
for i in data:
print i`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}