#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(I*))(^\1|,\2I|\2I)+$"
Local $sString = "I,II,III,IIII,IIIII,IIIIII,IIIIIII" & @CRLF & _
"I,II,III,IIII,IIIII,IIIIII,IIIIIIIIII" & @CRLF & _
"II,II,III,IIII,IIIII,IIIIII,IIIIIII" & @CRLF & _
"I,II,IIIIII,IIII,IIIII,IIIIII,IIIIIII" & @CRLF & _
"IIIIII,IIIIIII" & @CRLF & _
"III,IIII,IIIII,IIIIII"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")