$re = '/(-start|(?!^)\G)(.*?)FIND(?=.*end-)/';
$str = 'somes text -start bla bla FIND bla bla bla FIND bla FIND bla end-';
$subst = "$1$2NEW_WORD";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;