use strict;
my $str = 'http://url.com/wp-content/uploads/2009/09/name-of-the-file-150x150.png
http://url.com/wp-content/uploads/2009/09/name-of-the-file-1324x130.png';
my $regex = qr/http:\/\/url.com\/wp-content\/uploads\/\S+(?<!150x150)\.(?:jpg|jpeg|png|gif)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}