# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"abc(?:(?!abc|xyz).)*xyz"
test_str = "abc 1 abc 2 xyz 3 xyz"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.