use strict;
my $str = 'Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]';
my $regex = qr/(\[bold\]?)(.*?)(\[\/bold\]?)/ip;
my $subst = '<CharacterStyleRange FillColor=""> <Properties> <AppliedFont type="string">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";