// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\[bold\]?)(.*?)(\[\/bold\]?)").unwrap();
let string = "Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]";
let substitution = "<CharacterStyleRange FillColor=\"\"> <Properties> <AppliedFont type=\"string\">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}