import Foundation
let pattern = #"(\[bold\]?)(.*?)(\[\/bold\]?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<CharacterStyleRange FillColor=""> <Properties> <AppliedFont type="string">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)