import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0?\\d|[1][0-2])\\/(0?[1-9]|[0-2]\\d|[3][0-1])\\/(\\d{2})(?:(?:\\s(0?[1-9]|1[012])\\:([0-5]\\d)(?:\\s(AM|PM))?)?)$";
final String string = "12/31/00\n"
+ "5/5/14 12:04\n"
+ "05/05/24 5:54 AM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}