$re = '/^(0?\d|[1][0-2])\/(0?[1-9]|[0-2]\d|[3][0-1])\/(\d{2})(?:(?:\s(0?[1-9]|1[012])\:([0-5]\d)(?:\s(AM|PM))?)?)$/m';
$str = '12/31/00
5/5/14 12:04
05/05/24 5:54 AM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);