// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0?\d|[1][0-2])\/(0?[1-9]|[0-2]\d|[3][0-1])\/(\d{2})(?:(?:\s(0?[1-9]|1[012])\:([0-5]\d)(?:\s(AM|PM))?)?)$").unwrap();
let string = "12/31/00
5/5/14 12:04
05/05/24 5:54 AM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}