import Foundation
let pattern = #"^([\w.]+\.)\s+.+\sNS\s.+\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
piggyvoucher.com. 86400 IN SOA ns1.krystal.co.uk. admin.krystal.co.uk. (
2014060600 ;Serial Number
86400 ;refresh
7200 ;retry
3600000 ;expire
86400 ;minimum
)
piggyvoucher.com. 86400 IN NS ns1.piggyvoucher.com.
piggyvoucher.com. 86400 IN NS ns2.krystal.co.uk.
piggyvoucher.com. 14400 IN A 77.72.0.110
localhost 14400 IN A 127.0.0.1
mail 14400 IN CNAME piggyvoucher.com.
www 14400 IN CNAME piggyvoucher.com.
ftp 14400 IN A 77.72.0.110
cpanel 14400 IN A 77.72.0.110
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}