import re
regex = re.compile(r"[\w\-\.]+txt:route-policy\sGERENCIA_UBB_STATIC.+")
test_str = ("RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
"RMAGRJO-MTC01-01.txt:route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
"RMAGRJO-MTC01-01.txt- if tag eq 30210 then\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")