using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$";
string substitution = @"$1 $2 $1";
string input = @"== Heading 1 ==
lorem ipsum
=== Sub-Heading 1 ===
lorem ipsum
===Sub-Heading 2 with ugly formatting===
lorem ipsum
=== Sub-Heading 3 without closing equal signs
lorem ipsum
== Heading 2 with ~= in the middle ==
lorem ipsum";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}