$re = '/^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$/m';
$str = '== Heading 1 ==
lorem ipsum
=== Sub-Heading 1 ===
lorem ipsum
===Sub-Heading 2 with ugly formatting===
lorem ipsum
=== Sub-Heading 3 without closing equal signs
lorem ipsum
== Heading 2 with ~= in the middle ==
lorem ipsum';
$subst = "$1 $2 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;