import Foundation
let pattern = #"^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
== Heading 1 ==
lorem ipsum
=== Sub-Heading 1 ===
lorem ipsum
===Sub-Heading 2 with ugly formatting===
lorem ipsum
=== Sub-Heading 3 without closing equal signs
lorem ipsum
== Heading 2 with ~= in the middle ==
lorem ipsum
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)