# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-\d{4}-\d{2}-\d{2}.*$//gm;t' <<< "GN1RLWFH0546-2020-04-10-18-09-52-563945.txt
JOHN-DOE-2020-04-10-18-09-52-563946t64.txt
DESKTOP-OHK45JO-2020-04-09-02-27-11-451975.txt"