package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-\d{4}-\d{2}-\d{2}.*$`)
var str = `GN1RLWFH0546-2020-04-10-18-09-52-563945.txt
JOHN-DOE-2020-04-10-18-09-52-563946t64.txt
DESKTOP-OHK45JO-2020-04-09-02-27-11-451975.txt`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}