package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-9]{2}[-][A-JL-Z][A-Z][-][A-Z]{2}`)
var str = `11-AA-BB`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}