$re = '/[1-9]{2}[-][A-JL-Z][A-Z][-][A-Z]{2}/';
$str = '11-AA-BB';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);