$re = '/[^\d.|-]+/';
$str = '# sample output: 11:53:00p|0.0mm|1028.11s|75%|-4|';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;