package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\a|def|xyz|abc`)
var str = `I wish to know if a string contains one of "abc" "def" "xyz", etc, I could do it like`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}