using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-]\s++(.+$.+$.+$)";
string input = @"- hallo welt
-- hello world
Saluton Mondo
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko - s dad
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko
müll sd apodj9adj
müll sd apodj9adj
müll sd apodj9adj
- Bonjour tout le monde
Merhaba Dünya
-- moni Dziko";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}