package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$?([-A-Z0-9_ ]+)`)
var str = `ABC 123 123 534
$DEF564 456 5454`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}