re = /(?:https?:\/\/)?(?:www.|web.|m.)?(?:facebook|fb).com\/(?:video.php\?v=\/?|\?v=\/?|watch\/\?v=\/?|watch\/\?v=\/?)|\S+\/videos\/?/m
str = 'https://www.facebook.com/video.php?v=210218373654245
https://www.facebook.com/watch/?v=2601882823434382
https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://www.facebook.com/46etplus/videos/210218373654245
https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://m.facebook.com/watch/?v=210218373654245
https://web.facebook.com/watch/?v=210218373654245
http://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://www.facebook.com/Wickedgirlsblog/videos/210218373654245/
https://www.facebook.com/watch/live/?v=210218373654245
https://www.facebook.com/watch/?v=210218373654245
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end