re = /^ (?: aa (?= (?:aa)* (\1?+ b) ) )+ \1 $/mx
str = 'ab
aabb
aaaabbbb
aab
aaaabb
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end