#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?:(?:https?):\/\/)?(?:\S+(?::\S*)?@)?(?:(?:[a-z0-9][a-z0-9\-]*?[a-z0-9]+)(?:\.(?:[a-z0-9\-])*[a-z0-9]+)*(?:\.(?:[a-z]{2,})(:\d{1,5})?))(?:\/[^\s]*)?)(?:[ ]+[^< ]|\Z|\n)"
Local $sString = "jkNKLJNLKJASSDNBVKLJAVD http://www.google.com" & @CRLF & _
" http://www.google.com" & @CRLF & _
"<a href="http://www.w3schools.com">Visit W3Schools.com!</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")