const regex = /((?:(?:https?):\/\/)?(?:\S+(?::\S*)?@)?(?:(?:[a-z0-9][a-z0-9\-]*?[a-z0-9]+)(?:\.(?:[a-z0-9\-])*[a-z0-9]+)*(?:\.(?:[a-z]{2,})(:\d{1,5})?))(?:\/[^\s]*)?)(?:[ ]+[^< ]|\Z|\n)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:https?):\\\/\\\/)?(?:\\S+(?::\\S*)?@)?(?:(?:[a-z0-9][a-z0-9\\-]*?[a-z0-9]+)(?:\\.(?:[a-z0-9\\-])*[a-z0-9]+)*(?:\\.(?:[a-z]{2,})(:\\d{1,5})?))(?:\\\/[^\\s]*)?)(?:[ ]+[^< ]|\\Z|\\n)', 'ig')
const str = `jkNKLJNLKJASSDNBVKLJAVD http://www.google.com
http://www.google.com
<a href="http://www.w3schools.com">Visit W3Schools.com!</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}