re = /Job Title: ((?: *[A-Z]\w+){2,3})/
str = 'Job Title: Some Word Here AndThere
Job Title: Some Sq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end