$re = '/flavor=\"[^\"]+\(([^\)]+)/';
$str = '<182>1 2016-08-30T13:11:17.530157+02:00 cloudcapprorh01.boaweng.gsnetcloud.corp capacity.instances - - [timeQuality tzKnown="1" isSynced="1" syncAccuracy="946892"] diskconfig="MANUAL" availability_zone="BOAW-1" host="srvboaw01cnodep38.boaw-infra.gsnetcloud.corp" hypervisor_hostname="srvboaw01cnodep38.boaw-infra.gsnetcloud.corp" instance_name="inst-00001ff5" power_state="1" task_state="None" vm_state="active" launched_at="2015-07-23T07:18:03.000000" terminated_at="None" accessipv4="" accessipv6="" addresses="PRB_PRODSERV_LAB (Template 0) \\ Subnet 0=10.200.0.16" config_drive="" created="2015-07-23T07:17:59Z" flavor="sabor554??(adf) (1003)" hostid="76651d2e4c981ab8084dad155e52129580ed9fd4baf5fa628cd8bae8" id="61626999-026e-4d06-9eaa-835c0262b939" image="RHEL 7.0 (3fa495a8-fbb6-45c0-9c44-874b9016d4a3)" key_name="jdelarco" name="gitlab" volumes_attached="[]" progress="0" project_id="6e58b12be4bb4972bfb42812ee806065" properties="" security_groups="[{u\'name\': u\'default\'}]" status="ACTIVE" updated="2015-11-16T17:06:38Z" user_id="x100183" region=BOAW';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);