// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$").unwrap();
let string = "0566227662
0566227662
0041566227662
+41566227662";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}