package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)->(\d+)`)
var str = `channel->0->item->0->guid->0`
var substitution = "[\1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}