import Foundation
let pattern = #"->(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"channel->0->item->0->guid->0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)