#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xsJ)(?<=^|\v)" & @CRLF & _
"\h*+\*\h*+" & @CRLF & _
"(?:" & @CRLF & _
" (?:" & @CRLF & _
" (?P<annotation>" & @CRLF & _
" @(?P<name>\w++)" & @CRLF & _
" (?:" & @CRLF & _
" (?<=@param)\h++(?P<type>\w++(?:\[\])?)\h++\$(?P<variable>\w++)" & @CRLF & _
" |(?<=@return)\h++(?P<type>\w++(?:\[\])?)" & @CRLF & _
" |(?<=@throws)\h++(?P<class>\w++)" & @CRLF & _
" |(?<=@cache)\h++(?P<time>\d++)" & @CRLF & _
" |(?<=@roles)\h++(?P<roles>\w++(?:\h*+,\h*+\w++)*)" & @CRLF & _
" )?" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (?P<comment>\h++[^\v]++)?" & @CRLF & _
" (?:(?P<comment>\v)\h*+\*\h*+(?P<comment>[^\v@\h\*][^\v]++))*+" & @CRLF & _
" |(?P<description>(?:[^\v@\h\*][^\v]++)" & @CRLF & _
" (?:" & @CRLF & _
" \v\h*+\*\h*+[^\v@\h\*][^\v]++" & @CRLF & _
" )*+" & @CRLF & _
" )" & @CRLF & _
") "
Local $sString = "/**" & @CRLF & _
" * bla bla " & @CRLF & _
" *bla2 @ bla2 @" & @CRLF & _
" *" & @CRLF & _
" * bla bla 3" & @CRLF & _
" *" & @CRLF & _
" * @olivier voila" & @CRLF & _
" * @param string $sku1 bidule" & @CRLF & _
" *" & @CRLF & _
" * @param string[] $sku2" & @CRLF & _
" *" & @CRLF & _
" * @param string $sku3 toto bidule @" & @CRLF & _
" * machin truc" & @CRLF & _
" *" & @CRLF & _
" * @param string $sku4" & @CRLF & _
" * machin truc" & @CRLF & _
" *" & @CRLF & _
" * @deprecated" & @CRLF & _
" *" & @CRLF & _
" * @deprecated toto" & @CRLF & _
" *" & @CRLF & _
" * @throws Exception" & @CRLF & _
" * @throws Exception" & @CRLF & _
" * machin" & @CRLF & _
" * @return Cfe_Type_Product" & @CRLF & _
" * @cache 3600" & @CRLF & _
" * @roles toto, titi,truc , machin" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")